Vannin' Home
Posted By: vaNsquared Loud ticking from engine - April 30th 2021 3:15 pm
I have the original 350 in my 1980 G-20. Loud ticking that came on suddenly when accelerating from a stoplight. Just pulled the valve cover to find this situation on the driver's side. Passenger side looks/acts fine.
[Linked Image from i.postimg.cc]
Has anyone had something like this happen?
Posted By: Rusty_Pancelode Re: Loud ticking from engine - April 30th 2021 9:06 pm
Yes, but not on my van.

About 23 years ago, I bought a 1970 VW Beetle that the owner thought had a burnt valve.
When I got it home we popped the valve covers to find something very similar to what you've posted.
However, instead of the rocker being off the valve-stem, it was off of the push-rod.
I put it back like it was supposed to be, made the proper valve lash adjustment, and drove it for two years with no other issues until I pulled the engine apart to soup it up.

Check to see if the rocker nut backed off...
Check to see if the push-rod's bent...
Check to see if there's damage to the valve stem...

The slack came from somewhere, if nothing's obvious, it's possible that you've had a lifter failure, a valve spring failure, or that cam lobe has an issue.
Posted By: vaNsquared Re: Loud ticking from engine - May 01st 2021 2:39 am
Thanks @Rusty, this is a big help

I loosened the rocker arm, swiveled it out of the way, and pulled out a rather bent pushrod
[Linked Image from i.postimg.cc]
Dashed off to the junkyard and grabbed a handful of pushrods from an '82 305.
Used a washer and a socket to tap the split keeper back into place. Loosened up the valve a little in the process too. Sticky valve has not been cleared as a suspect at this point...
Popped in one of the used push rods, took the slack out of the rocker +3/4 turn for lash, and fired her up. Sure enough, sound gone!
Added some MMO to help free up anything that may be binding and causing trouble. If it happens again I'm ready lol
Posted By: KogonDodge Re: Loud ticking from engine - May 01st 2021 3:39 am
https://youtu.be/tUN-5qKxd3k?t=995

This guy had a similar thing
Posted By: Rusty_Pancelode Re: Loud ticking from engine - May 01st 2021 4:17 am
Originally Posted by vaNsquared
Thanks @Rusty, this is a big help

...Loosened up the valve a little in the process too. Sticky valve has not been cleared as a suspect at this point...


No problem.
Glad you got it working again.

I'd suspect that valve, too.
He'd better start acting right.
lol
Posted By: kursed Re: Loud ticking from engine - May 01st 2021 5:32 pm
Glad to see you're on the right track. I had a 69 C10 that was prone to one freaking rocker nut backing off. I just kept readjusting it and rolling it for about 6 months at a time.

I'm guessing the valve might be sticking too. Probably not too expensive of a rebuild to pop those heads off and have a machine shop go through them thoroughly.

Keep us posted on what you find out once you dig in.
Posted By: vaNsquared Re: Loud ticking from engine - May 07th 2021 9:16 pm
Thanks again for the help everyone!
I did the ol' sheet of paper over the tailpipe trick and can confirm that some exhaust valves are a little sticky.
The MMO and some regular exercise seems to be doing the trick so far. Hopefully it's just some gunk from sitting/idling in the driveway for a few months.
I'm also keeping one of the junkyard pushrods in the van a good luck charm. I've noticed things tend not to break when you have a spare on hand lol
Getting the heads reconditioned will probably not be too bad if it comes to it though, one of the advantages of an old Chevy van with a 350
© Vannin' Community and Forums