Vanning.com logo
Boxdin
Site Navigation


Advertisements
Recent Posts
Pop out window
by ReRide - August 10th 2022 9:41 pm
Seat bases mystery
by frscke1 - August 10th 2022 8:02 pm
Chevy g20 -85, Taillights, turn signals and more
by frscke1 - August 10th 2022 6:41 pm
Vanarama 10 at Carlisle Truck Nationals
by frscke1 - August 10th 2022 5:26 pm
back door lock won't turn
by Seattle Van Dude - August 10th 2022 10:56 am
Featured Links


Thread Like Summary
frscke1
Total Likes: 1
Original Post (Thread Starter)
1995 G20 4.3 V6 #783455 10/07/2021 4:59 PM
by OVANNER
OVANNER
I believe it has been mentioned on here multiple time but I just picked up this van and it ran great until I changed the battery and washed down the engine a little. Now it start right up but stalls quickly. Have been trying multiple things but with no success..

Any ideas Chevy Fans?
Liked Replies
Re: 1995 G20 4.3 V6 #783461 Oct 7th a 06:52 PM
by CatFish
CatFish
Check/troubleshoot the fuel pump relay operation and connector, also the oil pressure sending unit wiring. The computer will bypass the the oil pressure signal for a few seconds on start-up but if it doesn't see a reading after that it will shut off the fuel pump relay.
Worth a shot, you may have gotten the connections wet/etc when you cleaned it.
My2%
1 member likes this
Donate


discovery
Who's Online Now
0 members (), 2 guests, and 4 robots.
Key: Admin, Global Mod, Mod
Newest Members
LeaveNothingStock, BobButNotThatBob, Swede, trent_maka, RockwoodDoofus
12373 Registered Users
Top Posters (30 Days)
SDMickey 136
frscke1 56
kursed 51
NEmery 28
Lee7673 24
Forum Statistics
Forums68
Topics38,482
Posts544,360
Members12,373
Most Online177
May 8th, 2013

Powered by UBB.threads™ PHP Forum Software 7.7.4