Vanning.com logo
Boxdin
Site Navigation


Advertisements
Recent Posts
Hey there. New to the forum with a 90 G10
by Hotdog53 - October 25th 2020 6:34 am
1969 Econoline Shorty
by frscke1 - October 25th 2020 1:37 am
95 G20 Scavenger Hunt
by frscke1 - October 24th 2020 11:15 pm
1986 chevy G-20 short bed ,Florida
by newkirkinc1 - October 24th 2020 6:23 pm
Featured Links
Vanning.Com is a an authorized Amsoil Dealer


Previous Thread
Next Thread
Print Thread
Rate Thread
1987 G20 Code 43
#764566 August 08th 2020 6:38 pm
Joined: Jun 2020
Posts: 52
Likes: 2
journeyman
OP Offline
journeyman
Joined: Jun 2020
Posts: 52
Likes: 2
I've made this post after searching and reading many others here, and elsewhere.

I've got a 350 TBI. All stock. Code 43 from the check engine light as per the mechanic has told me.
The van runs and idles fine.

I don't have the van back from him yet, but I should this coming week. He has sort of tasked me with diagnosing this so we just don't end up throwing parts at it.

I plan to bridge the connectors and read it again. It'll be good to know how to do that.

I've searched around the internet quite a good bit, and I find different suggestions and solutions in each place I look.

The CEL comes on when the van is started. The "BRAKE" light is also on, mechanic found the valve to it is closed, meaning there was a leak at some point. A friend and I plan to replace the whole drum system.

I need to figure out what is causing the CEL without spending money on parts I don't need. I'm decently smart, and I have a multimeter. Everything I've read about this is for engines that are running poorly. The steps and suggestions are written horribly, the posts written long ago, scattered around different off-roading and chevy websites.

I'd really like to tackle this problem when I get the van back. I've got long tube hedmans and the full exhaust system ready to go on, and I plan to have an 02 bung put in. I obviously want to solve this CEL before having the exhaust done, as well as so the CEL is actually a working warning light, and not always on.

I'm doubtful that there is any single source of truth for troubleshooting the code 43, but I would really like to formulate a concrete attack plan. I appreciate the help ya'll.

Last edited by DrCaldre; August 08th 2020 6:40 pm.

1987 G20
2015 XL1200C
2010 E61
Re: 1987 G20 Code 43
DrCaldre #764567 August 08th 2020 7:12 pm
Joined: Jun 2010
Posts: 15,038
Likes: 5
Offline
Joined: Jun 2010
Posts: 15,038
Likes: 5
typed it in google and ...

Knock Sensor Error
The ECM receives a signal from the Knock sensor based on the amount of engine ping detected. The ECM uses information from this sensor to help calculate fuel delivery and spark timing.


SUNSHINE VANS-VAN DIEGO
ADRENALIN BY THE GALLON & CHASIN RACIN
ONE FOR THE DIRT & ONE FOR THE STREETS
'93 CHEVY G30 454 4X4 SPORTVAN EXT 146" WB
'92 CHEVY G30 454 BEAUVILLE EXT 146" WB
Re: 1987 G20 Code 43
DrCaldre #764569 August 08th 2020 8:27 pm
Joined: Jun 2020
Posts: 52
Likes: 2
journeyman
OP Offline
journeyman
Joined: Jun 2020
Posts: 52
Likes: 2
Thanks frscke, I obviously found that too. The coolant is behind that sensor. I have seen a lot of folks online saying how changing the sensor didn't banish the CEL. I'm a bit hesitant to spend the money on the part, and drain my coolant, without doing a little more troubleshooting.

Here's one of the posts I was talking about, it's not really something I can read and follow. I was hoping someone here might have a little more domain knowledge.

https://ck5.com/forums/threads/code-43.215245/

Last edited by DrCaldre; August 08th 2020 8:28 pm.

1987 G20
2015 XL1200C
2010 E61

Moderated by  Astro 

Link Copied to Clipboard
Donate


discovery
Who's Online Now
0 members (), 2 guests, and 3 robots.
Key: Admin, Global Mod, Mod
Newest Members
gumthps, Okibonoe, Tufbnme, Patekakes, CryptoChevy
11660 Registered Users
Top Posters (30 Days)
SDMickey 165
lukester 103
frscke1 50
NateB 25
NEmery 23
Forum Statistics
Forums68
Topics38,180
Posts537,051
Members11,660
Most Online177
May 8th, 2013

Powered by UBB.threads™ PHP Forum Software 7.7.4