Vanning.com logo
Boxdin
Site Navigation


Advertisements
Recent Posts
Help with Vin Number
by Rusty_Pancelode. June 04th 2020 12:58 pm
Vintage Gold Vein Mirrors- $3 each
by dragonvanman. June 04th 2020 12:49 pm
Vintage Auto Magazines
by Charlie99909. June 04th 2020 12:21 pm
Sharon Richards AKA: "Lady"
by Deathorvictory. June 04th 2020 11:45 am
'76 G30 Restomod
by frscke1. June 04th 2020 11:14 am
Hello from germany
by frediz. June 04th 2020 8:43 am
71' to 75' G10 Bumpers + Plus
by SDMickey. June 04th 2020 8:29 am
1977 Chevy G20
by glenna. June 04th 2020 8:09 am
1985 RAM B250 Royal Van - Project
by wrcsixeight. June 04th 2020 3:00 am
Original 1969 Ford E-200 for Sale
by samhain. June 03rd 2020 10:55 pm
Featured Links
Vanning.Com is a an authorized Amsoil Dealer


Previous Thread
Next Thread
Print Thread
Rate Thread
Page 1 of 2 1 2
1977 G20 Instrument cluster guages not working #760097
May 02nd 2020 12:07 am
May 02nd 2020 12:07 am
Joined: May 2020
Posts: 37
Bozeman, MT
J
jtozier406 Offline OP
newbie
jtozier406  Offline OP
newbie
J
Joined: May 2020
Posts: 37
Bozeman, MT
Just picked up a 1977 G20 and the instrument cluster is not working. The guy that I bought it from said he thought the computer on the back of the gauges did not match up with the plug. I am looking for any help I can get. Many of the wires in this van have been cut since it was recently stripped and painted. The instrument cluster did light up when turning on the lights and that is all. Pictures attached.

Attached Files 20200501_211145.jpg20200501_211148.jpg20200501_211317.jpg20200501_211236.jpg20200501_212006.jpg20200501_212028.jpg

1977 Chevy G20 with 350
Re: 1977 G20 Instrument cluster guages not working [Re: jtozier406] #760101
May 02nd 2020 4:26 am
May 02nd 2020 4:26 am
Joined: Jan 2014
Posts: 1,034
Staunton, VA
kursed Offline
old hand
kursed  Offline
old hand
Joined: Jan 2014
Posts: 1,034
Staunton, VA
Looks like the correct gauge set to me, so the "computer" which is actually just the printed circuit board should be correct as well. I would be willing to bet money the previous owner has cut a bunch of wires they shouldn't have. Get a repair manual, a decent multimeter, and start tracing wiring.

The speedometer works off of a cable that has a coupling which will thread onto or push onto the back of the speedometer. It's hanging out of the dash in the 3rd picture.

Welcome to the site by the way. Go do an intro and let us know more about the van.


[Linked Image]
Re: 1977 G20 Instrument cluster guages not working [Re: jtozier406] #760106
May 02nd 2020 10:52 am
May 02nd 2020 10:52 am
Joined: Dec 2017
Posts: 373
Portland, OR
Scrojira Offline
enthusiast
Scrojira  Offline
enthusiast
Joined: Dec 2017
Posts: 373
Portland, OR
Before you go doing a bunch of tedious grunt work tracing wires, are you sure the plug wasn't just inserted upside-down?


[Linked Image]
Re: 1977 G20 Instrument cluster guages not working [Re: Scrojira] #760107
May 02nd 2020 10:59 am
May 02nd 2020 10:59 am
Joined: May 2020
Posts: 37
Bozeman, MT
J
jtozier406 Offline OP
newbie
jtozier406  Offline OP
newbie
J
Joined: May 2020
Posts: 37
Bozeman, MT
Originally Posted by Scrojira
Before you go doing a bunch of tedious grunt work tracing wires, are you sure the plug wasn't just inserted upside-down?


Nice thought. I will check that tonight! Also on the side with the fuel and temp sensors there is a threaded piece on the back of the cluster. Is something supposed to attach to that?

I will get pictures up soon with an intro.


1977 Chevy G20 with 350
Re: 1977 G20 Instrument cluster guages not working [Re: jtozier406] #760109
May 02nd 2020 11:58 am
May 02nd 2020 11:58 am
Joined: May 2020
Posts: 37
Bozeman, MT
J
jtozier406 Offline OP
newbie
jtozier406  Offline OP
newbie
J
Joined: May 2020
Posts: 37
Bozeman, MT
Just tried flipping the plug and if I am not mistaken it can't be done. It looks like the plug has wider black plastic tabs on one side preventing it from installing the wrong way. I will look into tracing wires. I see some wiring diagrams for $20 online, are those any good?


1977 Chevy G20 with 350
Re: 1977 G20 Instrument cluster guages not working [Re: jtozier406] #760111
May 02nd 2020 12:10 pm
May 02nd 2020 12:10 pm
Joined: Dec 2017
Posts: 373
Portland, OR
Scrojira Offline
enthusiast
Scrojira  Offline
enthusiast
Joined: Dec 2017
Posts: 373
Portland, OR
Gotcha. The plug on my '78 can be pushed in either way.


[Linked Image]
Re: 1977 G20 Instrument cluster guages not working [Re: kursed] #760119
May 02nd 2020 2:50 pm
May 02nd 2020 2:50 pm
Joined: May 2020
Posts: 37
Bozeman, MT
J
jtozier406 Offline OP
newbie
jtozier406  Offline OP
newbie
J
Joined: May 2020
Posts: 37
Bozeman, MT
Originally Posted by kursed
Looks like the correct gauge set to me, so the "computer" which is actually just the printed circuit board should be correct as well. I would be willing to bet money the previous owner has cut a bunch of wires they shouldn't have. Get a repair manual, a decent multimeter, and start tracing wiring.

The speedometer works off of a cable that has a coupling which will thread onto or push onto the back of the speedometer. It's hanging out of the dash in the 3rd picture.

Welcome to the site by the way. Go do an intro and let us know more about the van.


The speedometer cable was plugged in. Should that have been working even if the other gauges are not since it is its own cable?


1977 Chevy G20 with 350
Re: 1977 G20 Instrument cluster guages not working [Re: kursed] #760147
May 03rd 2020 9:58 am
May 03rd 2020 9:58 am
Joined: May 2020
Posts: 37
Bozeman, MT
J
jtozier406 Offline OP
newbie
jtozier406  Offline OP
newbie
J
Joined: May 2020
Posts: 37
Bozeman, MT
Originally Posted by kursed
Looks like the correct gauge set to me, so the "computer" which is actually just the printed circuit board should be correct as well. I would be willing to bet money the previous owner has cut a bunch of wires they shouldn't have. Get a repair manual, a decent multimeter, and start tracing wiring.

The speedometer works off of a cable that has a coupling which will thread onto or push onto the back of the speedometer. It's hanging out of the dash in the 3rd picture.

Welcome to the site by the way. Go do an intro and let us know more about the van.


Is the Haynes repair manual the best option or should I try to hunt down a GM service manual?


1977 Chevy G20 with 350
Re: 1977 G20 Instrument cluster guages not working [Re: jtozier406] #760148
May 03rd 2020 10:20 am
May 03rd 2020 10:20 am
Joined: Jan 2001
Posts: 2,388
East Brady, PA
M
Meanmachine Offline
veteran
Meanmachine  Offline
veteran
M
Joined: Jan 2001
Posts: 2,388
East Brady, PA
The speedo cable should work on its own if attached properly. Pretty simple set-up, the cable goes from the back of the dash panel and attaches near the transmission. Would the threaded opening on the back be for an oil pressure line attachment. Haynes and Chilton manuals are usually the basics for repair, you can't beat having a factory manual, tons of detailed and comprehensive information along with illustrations, exploded views and wiring schematics.

Re: 1977 G20 Instrument cluster guages not working [Re: Meanmachine] #760149
May 03rd 2020 10:34 am
May 03rd 2020 10:34 am
Joined: May 2020
Posts: 37
Bozeman, MT
J
jtozier406 Offline OP
newbie
jtozier406  Offline OP
newbie
J
Joined: May 2020
Posts: 37
Bozeman, MT
Originally Posted by Meanmachine
The speedo cable should work on its own if attached properly. Pretty simple set-up, the cable goes from the back of the dash panel and attaches near the transmission. Would the threaded opening on the back be for an oil pressure line attachment. Haynes and Chilton manuals are usually the basics for repair, you can't beat having a factory manual, tons of detailed and comprehensive information along with illustrations, exploded views and wiring schematics.


Thanks, and yeah the Speedo was not working either but it was plugged in. I will try to find a factory repair manual.


1977 Chevy G20 with 350
Page 1 of 2 1 2

Moderated by  Astro 

Donate


Upcoming Events
Vanfest 2020
06-12-2020
discovery
Who's Online Now
0 registered members (), 6 guests, and 2 spiders.
Key: Admin, Global Mod, Mod
Newest Members
Astronaut, Gman28, Looking, MicroMachinery, RussellSherman
11462 Registered Users
Top Posters(30 Days)
SDMickey 307
kursed 71
Lee7673 60
frscke1 51
Forum Statistics
Forums68
Topics37,488
Posts532,419
Members11,463
Most Online177
May 8th, 2013

Powered by UBB.threads™ PHP Forum Software 7.6.1.1