Vanning.com logo
Boxdin
Site Navigation


Advertisements
Recent Posts
1985 Shorty Panel Van, Chevy “G” Series, $1600
by SaltLakeNorseman. June 06th 2020 4:03 pm
'76 G30 Restomod
by newkirkinc1. June 06th 2020 7:59 am
Drop spindles question
by DaveyRiot. June 05th 2020 8:27 pm
Help with Vin Number
by Deathorvictory. June 05th 2020 7:01 pm
MVI ?
by Meanmachine. June 05th 2020 6:22 pm
Sharon Richards AKA: "Lady"
by newkirkinc1. June 05th 2020 2:15 pm
Hello from germany
by Astronaut. June 05th 2020 12:28 pm
3rd gen Ford slider extender
by oldskool73. June 05th 2020 12:14 pm
butler 2020
by newkirkinc1. June 05th 2020 9:51 am
Original 1969 Ford E-200 for Sale
by SpaceTruckin. June 04th 2020 7:03 pm
Featured Links
Vanning.Com is a an authorized Amsoil Dealer


Previous Thread
Next Thread
Print Thread
Rate Thread
Page 5 of 6 1 2 3 4 5 6
Re: 1985 Dodge B150 fails emissions twice! [Re: Vanube] #753515
October 22nd 2019 2:53 pm
October 22nd 2019 2:53 pm
Joined: Sep 2019
Posts: 35
Denver
V
Vanube Offline OP
newbie
Vanube  Offline OP
newbie
V
Joined: Sep 2019
Posts: 35
Denver
Yes, timing is done correctly.

This was happening before setting the timing. I thought setting the timing would eliminate the problem.

All of those you listed are hooked up and none others.

I drove it briefly before setting the timing with the canister purge disconnected, air cleaner removed, EGR disconnected and plugged, distributer disconnected and plugged at the distributor and it ran as normal.

Re: 1985 Dodge B150 fails emissions twice! [Re: Vanube] #753516
October 22nd 2019 3:22 pm
October 22nd 2019 3:22 pm
Joined: Aug 2001
Posts: 12,050
Fircrest, WA
Reed Offline
Maniac
Reed  Offline
Maniac
Joined: Aug 2001
Posts: 12,050
Fircrest, WA
Define "ran as normal." Ran problem free? Or ran exhibiting the same symptoms of sputtering and poor performance?

Where do you have the distributor vacuum advance line attached on the carb?


Windows- they're what make a van worth owning!
Re: 1985 Dodge B150 fails emissions twice! [Re: Vanube] #753517
October 22nd 2019 3:56 pm
October 22nd 2019 3:56 pm
Joined: Sep 2019
Posts: 35
Denver
V
Vanube Offline OP
newbie
Vanube  Offline OP
newbie
V
Joined: Sep 2019
Posts: 35
Denver
"as normal" meaning without problems. Distributor is connected to "to distributor" port, passenger side front of carb below bowl vent fitting.

Re: 1985 Dodge B150 fails emissions twice! [Re: Vanube] #753518
October 22nd 2019 4:07 pm
October 22nd 2019 4:07 pm
Joined: Aug 2001
Posts: 12,050
Fircrest, WA
Reed Offline
Maniac
Reed  Offline
Maniac
Joined: Aug 2001
Posts: 12,050
Fircrest, WA
OK, disconnect all vacuum lines from the carb and reconnect one at a time until you find the one that causes the problems.


Windows- they're what make a van worth owning!
Re: 1985 Dodge B150 fails emissions twice! [Re: Vanube] #753519
October 22nd 2019 6:36 pm
October 22nd 2019 6:36 pm
Joined: Sep 2019
Posts: 35
Denver
V
Vanube Offline OP
newbie
Vanube  Offline OP
newbie
V
Joined: Sep 2019
Posts: 35
Denver
OK, well I disconnected the canister purge- I left all the other lines connected and tried to start the engine. No start. Now it won't start at all! Ha!

Tried to start it many times.

Re: 1985 Dodge B150 fails emissions twice! [Re: Vanube] #753520
October 22nd 2019 6:44 pm
October 22nd 2019 6:44 pm
Joined: Aug 2001
Posts: 12,050
Fircrest, WA
Reed Offline
Maniac
Reed  Offline
Maniac
Joined: Aug 2001
Posts: 12,050
Fircrest, WA
(1) where are you connecitng the cannister purge line on the carb?
(2) are you capping the fitting on the carb when you disconnect the hose?

Sounds like you might be fighting a vacuum leak issue.


Windows- they're what make a van worth owning!
Re: 1985 Dodge B150 fails emissions twice! [Re: Vanube] #753834
November 03rd 2019 6:53 pm
November 03rd 2019 6:53 pm
Joined: Sep 2019
Posts: 35
Denver
V
Vanube Offline OP
newbie
Vanube  Offline OP
newbie
V
Joined: Sep 2019
Posts: 35
Denver
Got it running. It was flooded. Pulled plugs and let it sit.

I'm going back to the timing.

1) when I checked the timing after installing the new distributor (in the exact orientation as the old distributor) it was over 30deg.

2) I set the timing to 10deg and the van runs poorly and and won't start after stopping the engine.

3) I am certain I used the the piston stop tool correctly and Actually... After making my marks on the balancer... My TDC lined up perfectly with one of the grooves.

So this thing seems to be running better at 30+deg than 10deg. Something tells me this is unusual.

Any words on this? Much appreciated!

Re: 1985 Dodge B150 fails emissions twice! [Re: Vanube] #753835
November 03rd 2019 7:39 pm
November 03rd 2019 7:39 pm
Joined: Feb 2016
Posts: 1,020
Portland, OR
Deathorvictory Offline
old hand
Deathorvictory  Offline
old hand
Joined: Feb 2016
Posts: 1,020
Portland, OR
I recently installed a new distributor in my 79 b200 and the replacement was installed exactly in the same clocked position and it wouldn’t run correctly and barely started. I had to re time despite the difference in position and she runs perfect. Not sure what’s up with these distributors, or why that happens but haven’t had any issues since and driven 700+ miles on these parts


1979 Dodge B200 Shorty, 1987 B250 Longy
Re: 1985 Dodge B150 fails emissions twice! [Re: Vanube] #754017
November 10th 2019 5:40 pm
November 10th 2019 5:40 pm
Joined: Mar 2007
Posts: 4,389
Dundee, Michigan
Ram4ever Offline

pooh-bah
Ram4ever  Offline

pooh-bah
Joined: Mar 2007
Posts: 4,389
Dundee, Michigan
Do you have a vacuum gauge you could attach to monitor the vacuum during operation? I'm with Reed on this; it seems to be the major missing data point.

Have you looked down the carb throat to be sure the butterflies are really completely closed when you first depress and release your accelerator pedal? Sometimes the linkage gets misadjusted or wears over the years, or the linkage springs wear out or wrong ones are installed, then various owners and mechanics start screwing around with the mixture and idle speed, getting some really bizarre combinations.

I've seen the control diaphragms blow out internally in those charcoal canisters, resulting in massive hidden vacuum leaks... Backfires are a common cause of this. If you attach a handheld vacuum pump to the master charcoal canister control fitting and pull a vacuum it should hold.

And on old vehicles where odd sputtering symptoms occur, I always suggest inspecting the fuel tank cap; the vents may become obstructed, causing the fuel system to pull a vacuum against the tank. You could try running the cap partially unseated to see if there's a difference.

And sometimes the throttle kickdown linkage can be so far off that weird things happen, especially during acceleration from low speed. If you do adjust idle speed, you really should revisit the kickdown adjustment just to be certain.


-It's been such a LONG TIME... BlueShift>> 1981 Dodge Ram B250 Custom Sportsman Maxi Van


[Linked Image]

It's what you learn after you know it all, that counts...

Are you living to work, or working to live?

[Linked Image]

Learning from my own mistakes is good, learning from yours would be much better! [Linked Image]
Re: 1985 Dodge B150 fails emissions twice! [Re: Vanube] #754657
December 04th 2019 11:18 pm
December 04th 2019 11:18 pm
Joined: Sep 2019
Posts: 35
Denver
V
Vanube Offline OP
newbie
Vanube  Offline OP
newbie
V
Joined: Sep 2019
Posts: 35
Denver
Thanks guys. I appreciate the response very much. I'm going to try these - and try doing a full tune on the carb and see where I'm at after that.

Page 5 of 6 1 2 3 4 5 6

Moderated by  Astro, nautic1, Ram4ever 

Donate


Upcoming Events
Vanfest 2020
06-12-2020
discovery
Who's Online Now
1 registered members (Rusty_Pancelode), 6 guests, and 2 spiders.
Key: Admin, Global Mod, Mod
Newest Members
Metro_Moulded_Parts, computerfix619, Astronaut, SkinnyDingle, Gman28
11465 Registered Users
Top Posters(30 Days)
SDMickey 300
kursed 69
Lee7673 60
frscke1 46
Forum Statistics
Forums68
Topics37,495
Posts532,489
Members11,465
Most Online177
May 8th, 2013

Powered by UBB.threads™ PHP Forum Software 7.6.1.1