Vanning.com logo
Boxdin
Site Navigation


Advertisements
Recent Posts
110" WB driveshaft alternatives
by frscke1. June 19th 2018 8:23 pm
Dr. Bob's Jokes Thread
by frscke1. June 19th 2018 8:21 pm
1985 G20 mechanical to hydraulic clutch and Hydroboost discussion
by Hasan Ben Sobar. June 19th 2018 8:08 pm
Japanese dodge build
by newkirkinc1. June 19th 2018 8:06 pm
Hey there from Tennessee.
by newkirkinc1. June 19th 2018 8:01 pm
Parting out 79 Street Van with Metal Logos
by JimmyMack. June 19th 2018 6:04 pm
temp settings for fan controller
by CatFish. June 19th 2018 5:56 pm
Project Dajiban! Modding my '99 Dodge Van
by catahoulabulldog. June 19th 2018 11:23 am
Converting my G20 to RHD and 4x4
by Overdrive915. June 19th 2018 10:20 am
How about 17" wheels?
by H20Toie. June 19th 2018 1:33 am
Featured Links
Vanning.Com is a an authorized Amsoil Dealer


Previous Thread
Next Thread
Print Thread
Rate Thread
TBI loss of power #736887
June 02nd 2018 12:31 pm
June 02nd 2018 12:31 pm
Joined: Mar 2011
Posts: 285
NY
J
jcd74 Offline OP
enthusiast
jcd74  Offline OP
enthusiast
J
Joined: Mar 2011
Posts: 285
NY
I am wondering if anyone else has had this problem. I have a sudden loss of power to the ECM, the observation is no check light, and the fuel gauge pinned on full. I going to take care of the obvious things today and get rid of the fusible links and switch to maxi fuse block. The common sense thing to check is the loss of the fuel sender and back pedal to the battery. I am afraid fixing the fusible links may not fix my problem as it is running now and I am wondering if anyone had the same problem and knows what the proper fix is.

Re: TBI loss of power [Re: jcd74] #736888
June 02nd 2018 12:34 pm
June 02nd 2018 12:34 pm
Joined: Mar 2011
Posts: 285
NY
J
jcd74 Offline OP
enthusiast
jcd74  Offline OP
enthusiast
J
Joined: Mar 2011
Posts: 285
NY
Ohh, sorry 89 G30 454, turbo 400

Re: TBI loss of power [Re: jcd74] #736891
June 02nd 2018 1:28 pm
June 02nd 2018 1:28 pm
Joined: Jun 2010
Posts: 13,354
Van Diego California
frscke1 Offline
frscke1  Offline

Joined: Jun 2010
Posts: 13,354
Van Diego California
Does it still have the original "pancake style" muffler ?

Mine had a loss of power & that was what fixed mine. No air thru no power


SUNSHINE VANS-VAN DIEGO
ADRENALIN BY THE GALLON & CHASIN RACIN
ONE FOR THE DIRT & ONE FOR THE STREETS
'93 CHEVY G30 454 4X4 SPORTVAN EXT 146" WB
'92 CHEVY G30 454 BEAUVILLE EXT 146" WB
Re: TBI loss of power [Re: jcd74] #736895
June 02nd 2018 4:03 pm
June 02nd 2018 4:03 pm
Joined: Mar 2011
Posts: 285
NY
J
jcd74 Offline OP
enthusiast
jcd74  Offline OP
enthusiast
J
Joined: Mar 2011
Posts: 285
NY
https://www.flickr.com/photos/151407392@N07/shares/b0HV90
Nope, electrical problem.

Re: TBI loss of power [Re: jcd74] #736896
June 02nd 2018 5:31 pm
June 02nd 2018 5:31 pm
Joined: Nov 2013
Posts: 920
West Texas
W
Wedgy Offline
old hand
Wedgy  Offline
old hand
W
Joined: Nov 2013
Posts: 920
West Texas
Originally Posted by jcd74
I am wondering if anyone else has had this problem. I have a sudden loss of power to the ECM, the observation is no check light, and the fuel gauge pinned on full. I going to take care of the obvious things today and get rid of the fusible links and switch to maxi fuse block. The common sense thing to check is the loss of the fuel sender and back pedal to the battery. I am afraid fixing the fusible links may not fix my problem as it is running now and I am wondering if anyone had the same problem and knows what the proper fix is.



Well, I once had an electrical problem with a short in the dash behind the instrument cluster on a Chevy work truck that scared thee Crap out of me with a huge puff of smoke. Drove fine, kept right on going, lost half the instruments at least!
White Knuckle drive, straight to Escondido Auto Electric. Short in the Cluster. The guys were laughing when I came in.

Smelled like the 4th of July...

A real ClusterShort for sure.

I'll look in my 1990 FSM book sitting right here, as I have the zaxt same drivetrain as you, see if it says anything. I do suspect, hopefully, just a short.

Are those the only 2 symptoms?

Re: TBI loss of power [Re: jcd74] #736919
June 03rd 2018 7:42 am
June 03rd 2018 7:42 am
Joined: Mar 2011
Posts: 285
NY
J
jcd74 Offline OP
enthusiast
jcd74  Offline OP
enthusiast
J
Joined: Mar 2011
Posts: 285
NY
When it happens everything else works. The problem is if it's working I can't find the problem. This started about two weeks ago, found one bad connection at the fuse box connector at the firewall. Fixed it made it home, next day stuck down the block, good for a week, problem for 20 min, ect.

Re: TBI loss of power [Re: jcd74] #736920
June 03rd 2018 8:16 am
June 03rd 2018 8:16 am
Joined: Nov 2013
Posts: 920
West Texas
W
Wedgy Offline
old hand
Wedgy  Offline
old hand
W
Joined: Nov 2013
Posts: 920
West Texas
GM jc,

Ok Eh!

Intermittent short causing no power to the ECM, causing vehicle to quit running. No codes.

Curious, Once it's running, did you check for any codes?

And they say that 30 year old Dodge wiring is crap...


"Who New? Blue"
1990 Chevy G30 454
Church Van, maternity division

"Old Blue"
1988 Dodge B250

"Cabin Cruiser"
'94 Dodge B350 www.xplorermotorhome.com/
Xplorer MH model 230 230 hp MPI 360 LA Wedgy OD auto

Old vans never really die if we chose to let them live
Re: TBI loss of power [Re: jcd74] #736921
June 03rd 2018 8:31 am
June 03rd 2018 8:31 am
Joined: Mar 2011
Posts: 285
NY
J
jcd74 Offline OP
enthusiast
jcd74  Offline OP
enthusiast
J
Joined: Mar 2011
Posts: 285
NY
Checking right now, it just dawned on me when I changed the heater core, I lost the screw for the speed sensor and left it loose behind the dash. I thought it was for the cruise control. I wonder if I will get that code.


Moderated by  Astro 

Donate


Upcoming Events
discovery
Instagram Feed
Who's Online Now
0 registered members (), 4 guests, and 6 spiders.
Key: Admin, Global Mod, Mod
Newest Members
athlonman, JimmyMack, Roostermt, NMVanner, Axe71
10396 Registered Users
Top Posters(30 Days)
frscke1 71
Reed 51
Wedgy 25
KeVan 24
Forum Statistics
Forums68
Topics34,354
Posts510,648
Members10,397
Most Online177
May 8th, 2013

Powered by UBB.threads™ PHP Forum Software 7.6.1.1
(Release build 20180111)
Page Time: 0.072s Queries: 15 (0.016s) Memory: 1.1260 MB (Peak: 1.7990 MB) Zlib enabled. Server Time: 2018-06-20 01:45:18 UTC