Vanning.com logo
Boxdin
Site Navigation


Advertisements
Recent Posts
Swapping a 81 chev grill to 77
by DaveyRiot. March 26th 2019 12:36 am
Used '70's mud flaps.
by Herson. March 25th 2019 11:40 pm
What Did You do To your Van Today?
by RoboforcerX2000. March 25th 2019 11:21 pm
Tuner4life's 1985 Chevy G20 4 Speed Build Thread
by RoboforcerX2000. March 25th 2019 11:16 pm
70 econoline SoCal area
by 70econo. March 25th 2019 11:14 pm
Dr. Bob's Jokes Thread
by Dyno_Dave. March 25th 2019 8:41 pm
Road Runner 1988 Markiii
by Dyno_Dave. March 25th 2019 8:36 pm
New Vanner from north jersey
by Dyno_Dave. March 25th 2019 8:34 pm
Bustout by T.I.T April 13th Bolivar Ohio.
by newkirkinc1. March 25th 2019 7:23 pm
1988 G20 ( MINT ) powder puff
by newkirkinc1. March 25th 2019 7:21 pm
Featured Links
Vanning.Com is a an authorized Amsoil Dealer


Previous Thread
Next Thread
Print Thread
Rate Thread
Instrument Cluster Issues Dodge B250 1992 #733048
February 14th 2018 1:27 pm
February 14th 2018 1:27 pm
Joined: Feb 2018
Posts: 1
UK
B
bras Offline OP
stranger
bras  Offline OP
stranger
B
Joined: Feb 2018
Posts: 1
UK
Hi All,

RE 1992 Dodge Ram B250 5.2V8 318 engine

Hello...Newbie here.

I'm struggling to resolve a issue the van has recently developed where the instrument cluster seems to not be working correctly, i'm suspecting a grounding connection but not sure where this can be found, I have checked all the ones i know of (engine block and bulkhead) and have cleaned them up well including checking connectors and continuity of wiring, but no change. The dash is grounded but I cant see a specific ground for the instrument cluster. I have checked/removed the cluster and I don't think the issue is here. I also checked the ABS and speed sensor in the diff and that fell apart in my hands, now replaced but no change to the cluster issue. I have not changed the front speed sensor as that appears fine.

The symptoms are when the brake or headlights are activated the oil and water temp shoot through the roof, also when indicating the dials flutter slightly and the speedo is very intermittent, but generally not working at all, particularly when the brake is applied.

I have a Haynes manual on order but hoping to sort this sooner as I have some one to view to buy next week, as I am VERY reluctantly selling due to relocation overseas, sad times.

Any help, particularly on the ground location for the instrument cluster would be well received.

There is little support or resource here in the UK for these vehicles so hoping someone over the pond can help!.

Cheers
bras


Re: Instrument Cluster Issues Dodge B250 1992 [Re: bras] #733050
February 14th 2018 1:40 pm
February 14th 2018 1:40 pm
Joined: Jun 2010
Posts: 14,100
Van Diego California
frscke1 Offline
frscke1  Offline

Joined: Jun 2010
Posts: 14,100
Van Diego California
Welcome to the site bras ... the dodge boys will be along shortly ...

Again welcome !


SUNSHINE VANS-VAN DIEGO
ADRENALIN BY THE GALLON & CHASIN RACIN
ONE FOR THE DIRT & ONE FOR THE STREETS
'93 CHEVY G30 454 4X4 SPORTVAN EXT 146" WB
'92 CHEVY G30 454 BEAUVILLE EXT 146" WB

Moderated by  Astro, Ram4ever 

Donate


Upcoming Events
discovery
Who's Online Now
0 registered members (), 0 guests, and 8 spiders.
Key: Admin, Global Mod, Mod
Newest Members
Cchill7, Juntao_DW, 72EconoMI, IncendiaClaymore, AbbyG20
10816 Registered Users
Top Posters(30 Days)
frscke1 73
CatFish 60
Lister 29
Forum Statistics
Forums68
Topics35,507
Posts518,221
Members10,817
Most Online177
May 8th, 2013

Powered by UBB.threads™ PHP Forum Software 7.6.1.1