Vanning.com logo
Boxdin
Site Navigation


Advertisements
Recent Posts
Stinky van
by Dyno_Dave. January 18th 2019 8:26 pm
Brrrrrrrrrrrr!
by Meanmachine. January 18th 2019 5:43 pm
Softer, longer lasting Rain Gutter Seam Sealer?
by BushcraftVan. January 18th 2019 3:49 pm
1978-1982 chevy van parting out
by jcd74. January 18th 2019 12:47 pm
new guy intro
by Lee7673. January 18th 2019 10:22 am
My new 77 Dodge project!!!!
by Lee7673. January 18th 2019 9:23 am
Dr. Bob's Jokes Thread
by newkirkinc1. January 18th 2019 7:29 am
Sold for $59,000
by amx. January 17th 2019 6:00 pm
Featured Links
Vanning.Com is a an authorized Amsoil Dealer


Previous Thread
Next Thread
Print Thread
Rate Thread
84 g20 bad vibration help #727889
September 17th 2017 1:27 pm
September 17th 2017 1:27 pm
Joined: Sep 2017
Posts: 5
eastern washington
H
hickman Offline OP
stranger
hickman  Offline OP
stranger
H
Joined: Sep 2017
Posts: 5
eastern washington
hey all. I have a 84 chevy g20 camper van. it vbrates real bad from 30mph to about 55, its def. coming from the drivline. i have checked the ujoints and they look fine. the carrier bearing has a little movement but not allot. I can tell there is some read drivline wobble from just behind the carrier bearing. any thoughts?

Re: bad vibration help [Re: hickman] #727890
September 17th 2017 2:07 pm
September 17th 2017 2:07 pm
Joined: Jun 2010
Posts: 13,925
Van Diego California
frscke1 Offline
frscke1  Offline

Joined: Jun 2010
Posts: 13,925
Van Diego California
I have a 2 pc drive shaft also & the carrier bearing needs to be tight.

Drive shaft unbalanced ?

All u-joints LOOK fine .... When was the last time you changed them ?



When you change gears does it go CLUN CLUNK....that is a sign of a bad u-joint.

It / they may still be the culprit ... how long has the veh been sitting ?

Last edited by frscke1; September 17th 2017 5:34 pm.

SUNSHINE VANS-VAN DIEGO
ADRENALIN BY THE GALLON & CHASIN RACIN
ONE FOR THE DIRT & ONE FOR THE STREETS
'93 CHEVY G30 454 4X4 SPORTVAN EXT 146" WB
'92 CHEVY G30 454 BEAUVILLE EXT 146" WB
84 g20 bad vibration #728592
October 06th 2017 1:28 pm
October 06th 2017 1:28 pm
Joined: Sep 2017
Posts: 5
eastern washington
H
hickman Offline OP
stranger
hickman  Offline OP
stranger
H
Joined: Sep 2017
Posts: 5
eastern washington
hi all, I have a 84 g20 camper van that has a real bad vibration from about 35mph to about 50mph. ive checked tires, replaced ujoints and carrier bearing and still have the vibration. just wondering if anyone might have had this problem in the past? any ideas?
thanks

Re: 84 g20 bad vibration [Re: hickman] #728607
October 06th 2017 6:58 pm
October 06th 2017 6:58 pm
Joined: Jan 2001
Posts: 2,097
Kellettville, PA
M
Meanmachine Offline
veteran
Meanmachine  Offline
veteran
M
Joined: Jan 2001
Posts: 2,097
Kellettville, PA
How old are the tires, bad tires will give a thumping sound, similar to a bad u-joint, or a brake could be holding up.


Moderated by  Astro 

Donate


Upcoming Events
discovery
Who's Online Now
1 registered members (1 invisible), 4 guests, and 5 spiders.
Key: Admin, Global Mod, Mod
Newest Members
Noah, Delbert359, Sportsmobileguy, textual, lynchmob2000
10716 Registered Users
Top Posters(30 Days)
frscke1 35
Forum Statistics
Forums68
Topics35,200
Posts516,274
Members10,717
Most Online177
May 8th, 2013

Powered by UBB.threads™ PHP Forum Software 7.6.1.1