My Fuel injected '89 has both the oil light, and the OP gauge, and now, as well, a mechanical OP gauge. I believe both light and gauge were controlled by the same sender on mine.

While my oil light never came on engine running, I was noticing very low oil pressure on the stock gauge at hot idle. I was going to buy a tester, but then saw I could install a mechanical OP gauge for less money.

I put it here:[Linked Image]

BTW, those Stock fuse holders were so extremely oxidized that recently they were intermittently cutting out on the wiper motor and brake light circuits. The replacement fuse is for the blower motor. It originally burnt out before my ownership, and many aftermarket fuse holders have melted since, but this current 8 awg Maxifuse holder has proven problem free. The fuse is to be 30 amps, but this 20 amp one has not yet blown.

Cutting a hole in the dash there was a chore, as one is cutting through metal. Dremel and many a cut off wheel were required.

I now have a red LED light in the gauge. It is harder to see the orange needle, but not terribly so. The incandescent bulbs were too bright and distracting.

I 'T'd the line with commonly available 1/8" NPT plumbing fittings, so that my original gauge and light still work. This is what my OEm electrical OP sender looks like
[Linked Image]

I see RockAuto shows at least 4 different OP senders for an '88 with a 360.

The mechanical OP gauge is SOOOOo much better. One can see instant responses in OP with engine rpm. One can determine when the oil is as hot as it normally gets, and this is well behind the coolant temp during warm up, and one can see the differences in different grades of oil and even see lower readings near the end of an oil change interval as the oil shears to a slightly lighter grade or gets diluted with fuel.

Before I had a tach, on one X country journey my Lockup torque converter was kicking on and off at highway speeds very quickly and fairly smoothly, and the OP gauge revealed the higher rpms when it would kick out. It was a dirty and improperly adjusted brake light switch causing it to drop out and re engage on road irregularities.

My Mechanical OP gauge will read ~68PSI when cold at any rpm. This is the bypass relief setting. When hot the maximum pressure is 62PSI, and that occurs at nearly 3000 RPM with M1 0w-30 AFE oil. 62 PSI occurs at lower RPM's with thicker oils when hot. Whenever the oil pump is in bypass, there is more parasitic drag on the motor than need be. It is not Oil PSI keeping metal parts from grinding against each other, it is the film strength of the oil. The PSI relates to how quickly the oil is pumped through the engine.

There is very little correlation between the OEM gauge, and the mechanical gauge. It takes about 45 seconds of the same rpm for the OEM gauge to follow the general pressure, whereas the mechanical gauge responds instantly to engine rpm. The OEm gauge does not swing as wide either, and is a lazy stoned drunk in comparison and just as trustworthy.

My Mechanical gauge needle, with hot as it gets 0w-30 oil, will read 14PSI and bounce between 14 and 16 rapidly at 525 rpm. While my OP gauge goes upto 100 PSI, at never sees anything over 70, so that portion of the sweep, and below 10PSI is useless. Mine is a cheapo Equus gauge. Perhaps an Autometer's needle will swing further making it easier to read.

Do note that with mechanical OP gauges one is bringing a hollow tube of Hot oil into the back of the gauge and chafing and failure can be messy and dangerous. They give a plastic tube with the cheap gauges. One can use copper tubing instead for more peace of mind. I took extra steps to prevent chafing or kinking of the provided Plastic/Nylon hose in early 07 when I installed mine.

Remember that OP is not a more is better thing. It is an ' as long as the minimum recommend PSi is exceeded at such and such and RPM, all is still well' sort of thing.

If more OP was better, we should all run 85w-140 gear oil, which is about the thickness of that Lucas Oil stabilizer crap which one should only add when the engine is so worn it can no longer maintain adequate oil pressure with the normal, properly formulated motor oil.

Lucas has 0 additives, and dilutes the additives blended into the proper motor oil, and as such should not be used. Lucas also makes some motor oils get all foamy when pumped through the oil pump, and you do not want foamy oil pumped into the bearings. Foamy oil can however absorb sound and make the engine appear quieter, when in fact more engine wear is taking place from a compromised oil film strength because of the aeration. Lucas Oil Stabilizer, the used car salesman's best friend. Well marketed junk.
If one desires thicker oil, buy thicker oil, at least this oil will have the proper add pack of detergents, extreme pressure friction modifying and anti wear additives. Sorry for the off topic rant.

I'm guessing you got your distributor working well enough that you are confident enough to move on?